Potential permission errors due to Salesforce resetting permission set groups

Incident Report for FinDock

Resolved

Over the past few days, we have monitored the issue and restarted stalled processes that were impacted. Recently, we have not observed any further issues. Given this, we will proceed with closing the matter while continuing to work with Salesforce to ensure a resolution before our next release. If you experience any related issues, please let us know.
Posted Jan 31, 2025 - 13:24 CET

Update

To help mitigate the permission set group issue we determined we can trigging adding permission sets from activated packages to FinDock permission set groups through another Core update. This update is being pushed right now. The update does not introduce functional changes. When the update is installed, FinDock adds permission sets from packages to the groups, and the group permissions are recalculated. This update should unblock FinDock functionality, but please note that you will still need to check and potentially re-make customizations you added to FinDock permission set groups.
Posted Jan 29, 2025 - 12:37 CET

Monitoring

Orgs that use FinDock permission set groups (https://docs.findock.com/setup/permission-set-groups) may be seeing permission-related errors after the January '25 production release.

NOTE: Customers that use classic permission sets are not impacted!

This is related to a Salesforce issue that unfortunately was not fully resolved by Salesforce.

For certain orgs, when an ISV package is installed or updated, permission set groups may be reset. This removes customizations such as permission sets added from other FinDock packages and your own changes, like a muting permission set. Please follow the steps we have outlined in this new FAQ (https://docs.findock.com/faq/why-are-findock-permission-group-changes-reset) to check and restore FinDock permission set groups.
Posted Jan 28, 2025 - 16:31 CET
This incident affected: FinDock Core & Source packages, File processing (ProcessingHub), (Online) Payment API / Payment Service Providers, and Notifications from Payment Service Providers (WebHub).