The scheduled maintenance has been completed. The scheduled maintenance has been completed. We will continue our own elevated monitoring as a precaution, but at this time, no further action is required.
Posted Jun 29, 2026 - 20:15 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2026 - 18:15 CEST
Scheduled
This hotfix resolves an issue where a race condition could lead to a failure in the recently rolled out Refresh Token Rotation (RTR) mechanism. The race condition would cause ProcessingHub to disconnect.
Posted Jun 29, 2026 - 18:04 CEST
This scheduled maintenance affected: File processing (ProcessingHub).