Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 20:00 CET
Scheduled
This hotfix adds missing permissions for File Reference and Job Group Identifier fields, required for batch matching through Guided Matching, to the classic permission sets PaymentHub All FLS, PaymentHub Integration Base, and PaymentHub Operations.
Posted Mar 27, 2025 - 18:08 CET
This scheduled maintenance affected: FinDock Core & Source packages.