Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 20:00 CEST
Scheduled
Changes introduced in the May ’26 release caused payment schedule generation to fail when using a custom payment reference without a generated payment reference. This hotfix restores proper handling for custom payment references.
Posted May 20, 2026 - 11:24 CEST
This scheduled maintenance affected: FinDock Core & Source packages.