Salesforce Ongoing Incident Impacting FinDock

Incident Report for FinDock

Resolved

The incident with Salesforce Services (https://status.salesforce.com/generalmessages/10001540) is now resolved. Based on our investigations, there are no further ongoing payment processing disruptions. We have identified and unblocked customers that were affected and in touch with others still needing assistance. In some cases, mandate and payment schedules that where schedules to run yesterday did not successfully start on ProcessingHub. You may want to check yesterday's schedules to ensure they ran as expected. If you still run into issues ,you can contact FinDock Support.
Posted Jun 11, 2025 - 11:39 CEST

Update

The impact of an incident with Salesforce Services (https://status.salesforce.com/generalmessages/10001540) appears to be subsiding. We are now investing if there are any actions FinDock can take to help customers recover from payment processing disruptions.
Posted Jun 11, 2025 - 08:14 CEST

Identified

The incident with Salesforce Services (https://status.salesforce.com/generalmessages/10001540) has seen some promising development. However, FinDock customers continue to experience disruptions, including connections issues with PSPs, blocked processes that FinDock also cannot access or resolve, processes not starting as expected, and general ProcessingHub connection instability. We are hopeful the incident will be resolved soon given the latest updates from Salesforce.
Posted Jun 10, 2025 - 17:46 CEST

Investigating

Due to an ongoing incident with Salesforce Services(https://status.salesforce.com/generalmessages/10001540), some FinDock processes, particular those running on ProcessingHub, may fail or appear stuck. We are monitoring the situation closely. Currently we have not identified actions FinDock can take to help mitigate the impact.
Posted Jun 10, 2025 - 11:12 CEST
This incident affected: File processing (ProcessingHub).