Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2025 - 19:00 CEST
Scheduled
This hotfix resolves two issues. The first, Norway KID, was an issue that in certain scenarios could lead to a customer ID being reused for different customers due to how the last provisioned customer ID was stored and fetched across different mandate creation methods. This has now been fixed to ensure all creation methods properly handle the last provisioned customer ID. For Mollie retries, we identified a potential double collection scenario where an unhandled exception leads to payment creation at Mollie as well as a retry (and potential duplicate payment) from FinDock. This is resolved by no longer retrying unhandled exceptions.
Posted Sep 02, 2025 - 16:30 CEST
This scheduled maintenance affected: (Online) Payment API / Payment Service Providers.